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! References 

MultiSpec Introduction (http://dynamo.ecn.purdue.edu/~biehl/MultiSpec/documentation.html) 
MultiSpec Tutorials (http://dynamo.ecn.purdue.edu/~biehl/MultiSpec/tutorials.html) 

! Objective 
The objective of these exercises is to get some experience using a freeware package named 
MultiSpec.  Specifically you will display multispectral and thematic images, combine separate 
image files into one file, run unsupervised classifications (ISODATA), run supervised 
classifications and display the results plus obtain experience with some utility functions. 
Background.  MultiSpec is a multispectral image data analysis software application that was 
developed at Purdue University. It is intended to provide a fast, easy-to-use means for analysis of 
multispectral and hyperspectral image data, such as that from Landsat, SPOT, MODIS, 
Quickbird, IKONOS, Airborne Visible-Infrared Imaging Spectrometer (AVIRIS), EO-1 
Hyperion, ASTER and many others. The primary purpose for the system was to make new, 
otherwise complex analysis tools available to the general Earth science community. It has also 
found use in displaying and analyzing many other types of non-space related digital imagery, 
such as medical image data and in K-12 and university level educational activities. 
 

MultiSpec has been implemented for both the Apple Macintosh and Microsoft Windows 
operating systems (OS).  Although copyrighted, MultiSpec with its documentation is distributed 
without charge. The Macintosh and Windows versions and documentation on its use are 
available from the World Wide Web at: http//dynamo.ecn.purdue.edu/~biehl/MultiSpec/. 
 

MultiSpec is copyrighted (1991-2009) by Purdue Research Foundation, West Lafayette, Indiana 
47907. 

Exercise List 
  1:  Display and Inspection of Image Data 
  2:  Combining Separate Image Files into a Single Multispectral Image File 
  3:  Unsupervised Classification 
  4:  Supervised Classification – Select Training Fields 
  5:  Classification 
  6:  View Classification Map 
  7:  Classification Probability Map 
  8:  Overlay Shape Files on Image Window 
  9:  Selecting Areas and the Coordinate View 
10:  Image Enhancement  
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! Exercise 1: Display and Inspection of Image Data 
Requirements:  MultiSpec application and image titled “ag020522_DPAC_cd.lan”. 
In this exercise, we will display an aircraft image of a portion of the Davis Purdue Agriculture 
Center in Randolf County, Indiana and view the data in several ways using MultiSpec. 
1.1 Start MultiSpec using the icon on the desktop or from MultiSpec in the Startup Menu. 

1.2 From the File menu choose Open Image. . ..  A dialog box will open to allow one to select 
the data file one wishes to use. 

1.3 Select ag020522_DPAC_cd.lan in the Exercise1 folder and Open, or simply double-click 
on ag020522_DPAC_cd.lan 
This is a segment (709 lines x 1501 columns of pixels) of a 3-channel image of DPAC 
collected on May 22, 2002. Next a dialog box will appear to allow one to choose among 
various options for the image display. 

 
 

 Note that by default, the area designated for display is the whole scene and the 3-Channel 
Color Display Type is selected. The default settings call for the Red screen color to be 
derived from band 3, Green from band 2 and Blue from band 1. These particular choices 
will cause the screen image to be in a 3-color format approximating Color Infrared film.  

 
 Select OK. 
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1.4 This step may not occur for all situations.  If the data histogram has not previously been 
calculated and stored (in a .sta file), another dialog box will be presented allowing the 
choice of regions to be histogrammed, so that the channel data values can be properly 
assigned to screen colors. The default options built into this dialog box are satisfactory, so 

 

 Select OK to begin the histogramming. 
 

After the histograms of all of the channels have been computed, the information will be 
saved to a file named “ag020522_DPAC_cd.sta” so that they will not have to be re-
computed when needed again. 
[Note that if a .sta file already exists with the default name, a dialog box will be presented 
allowing you to overwrite the existing .sta file or save to a different location.] 

1.5 The image of the data will now appear.  Notice that just above the image window in the 
toolbar there are two small boxes with large and small “mountains”. These are image 
zooming buttons allowing one to zoom in (large mountain) or out (small mountain) from 
the current image scale. Just to the left of the image zooming buttons is another button 
which shows X 1 in grayed form. This button allows one to go to X1 magnification 
directly. The current zoom magnification is displayed along the bottom of the MultiSpec 
application window in the box labeled “Zoom=”. 
Some other options are to hold the ‘Ctrl’ key down while zooming to change the zoom step 
factor to 0.1 instead of 1. In other words, the zoom factor will change from 1.0 to 1.1 to 1.2 
etc. instead of 1, 2, 3, etc. (Note that one uses the ‘Option’ key on the Macintosh version to 
do this.) 
One can make a selection within the image by left click-hold in the image window, drag to 
select a rectangle, and then releasing the left mouse button. If a selected area exists in the 
image, any zooming will be centered on the selected area if possible. Clear selection using 
the “Delete” key. 

1.6 Next one can view a side-by-side channel display for data quality inspection.  From the 
Processor menu, select Display Image… to bring up the display dialog box. Then select 
Display Type “Side-by-Side Channels”, and select OK to display all three channels in the 
image side by side. 

 

 

Vegetation 
Areas 
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 The above image window will be displayed (after zooming out) which shows all three 
channels displayed side-by-side. Note that the vegetation areas in channel 3 are brighter 
than the same areas in channels 1 and 2. 

 The side-by-side channel display is a good way to verify that the channels are registered 
correctly. In other words, the same location in the image is at the same pixel location in all 
channels. To do this, select an area in one channel near a field intersection. This same 
selected area will be drawn in all of the channels. One can then verify that the selected area 
is at the same location in each channel. 

 Redisplay the 3-channel image with channels 3, 2 and 1 as Red, Green and Blue.  
1.7 Coordinate View. One can also display a “coordinate view” along the top of the image to 

present the cursor (mouse) location and selected areas in the image. To do this, select 
Coordinate View from the View menu. 

 
 

 

 If map coordinate information exists for the image, one can display the coordinates as map 
units. Use the popup menu on the left side of the coordinate view to select the map units.  
The area of the selection can be displayed as the number of pixels or in units of acres, 
hectares, etc using the popup button to the left of “Scale”.  The scale of the image will also 
be displayed. 

 
 For this image, if one selects the Edit–>Image Map Parameters… menu item and set the 

UTM Zone to 16 and the Datum to “WGS 84” and then select OK; one can also display the 
cursor coordinates as latitude-longitude.  Note that the format that this image file is stored 
in (ERDAS *.lan) does not allow for storage of this information. Other image file formats 
such as GeoTIFF do. 
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1.8 The 1-channel Thematic display type is useful to display "product" type images such as 
MODIS NDVI or any of the other many MODIS products.  
 

 
 

The data values are grouped into the desired number of levels and a legend is displayed to 
the left of the image indicating which palette colors are associated with each range of data. 
(See illustration below.) One can also enter a factor to multiply the data values displayed in 
the legend by to reflect the actual measurement unit. Sometimes the data value may be the 
measurement value times 100 or 1000. One can use the Min/Max User Specified dialog 
box item to set the min and max values for the range of data to be displayed. Black is the 
default color for data values less than the minimum and white is the default color for values 
greater than the maximum. (Note: This feature can be considered as a supervised 1-channel 
levels classifier.) 

 

 
 

One can use the Reformat - Change Image File Format processor to create thematic images 
based on what is displayed in the image window. 
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!  Exercise 2:  Combining Separate Image Files into a Single Multispectral Image File. 
Requirements:  MultiSpec application and images titled “L7_000606_Indy_sub_Bxx.tif”. 
 

One can use the "Logically Linking" capability in MultiSpec to link several image files together 
to be treated as one image file in an image window and/or create a new image file that 
incorporates all of the separate images. For example many times one will receive Landsat images 
from the EROS Data Center either by electronic download or on a CD/DVD that contains one 
file for each of the 7 bands. This exercise will illustrate how to do this. 
 

Note that one can start with step 2.2 if all of the images files to be linked are at the same spatial 
resolution. 
 

2.1 Handling Differing Spatial Resolutions: The thermal channel for many Landsat data sets 
may be at a different spatial sampling than that for the reflective channels.  One cannot link 
the thermal channels without first creating a new thermal image file that has the same 
effective spatial sampling as that for the reflective channels. One can do this with a couple 
of additional steps using the Processor–>Reformat–>Rectify Image… menu item in 
MultiSpec. The following steps are specifically for Landsat 7 thermal data. They can be 
modified for other kinds of images. 

 

 - Open band 1 (L7_000606_Indy_sub_B1.tif) for the set of multispectral images to be 
linked using the File–>Open Image… menu item. The “Display Multispectral Image” 
dialog box will be presented to allow one to display the selected image.  One may display 
the image or just cancel the dialog box.  A blank multispectral image window will continue 
to be display.  This will become the “active” image window that represents the first image 
file that will be used in the next steps. 

  

 - Open the first thermal band (L7_000606_Indy_sub_B61.tif).  
 

 - Make sure the image window for the thermal channel is the active image window and 
then select the Processor–>Reformat–>Rectify image… menu item. Select “Reproject” in 
the Rectification Settings group in the “Set Image Rectification Parameters” dialog box as 
illustrated in the figure below.  Also verify that “L7_000606_Indy_sub_B1.tif” is the 
reference image. 
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 - Select OK and enter the name for the new rectified thermal image 

(L7_000606_Indy_sub_B61_30m.tif). A new thermal image will be created such that it 
contains a thermal value that matches the location for each pixel in the reference image 
using nearest neighbor as the sampling scheme.  

 

 - Close the first thermal image window and open the second thermal band 
(L7_000606_Indy_sub_B62.tif). Follow the same procedure used above to create 
“L7_000606_Indy_sub_B62_30m.tif”. 

 

2.2 Open the first multispectral image as one normally would using the File->Open Image… 
menu item.  The “Display Multispectral Image” dialog box will be presented to allow one 
to display the selected image.  One may display the image or just cancel the dialog box.  A 
blank multispectral image window will continue to be display.  This will become the 
“active” image window that represents the first image file that will be used in the next 
steps. 
 

2.3 To link an additional image disk file to the active image window, use the File->Open 
Image… menu item again. This time the 'Link to active image window' option is displayed 
in the lower-left portion of the dialog box. Check this box and select the 2nd image file 
(such as band 2 illustrated in the figure below) to be linked to the active image window. 
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As long as the ‘Link to active image window' box is checked and Cancel is not selected, the 
open image dialog box will automatically be displayed to allow the user to add additional 
image files to the active image window. The title for the open image dialog box will 
indicate the number of files that will be linked with the selection to be made. Also the name 
of the image window is prefaced with 'Ln-' where n is the number of files that are linked for 
that image window. 

 

2.4 Select ‘Cancel’ after all desired image files have been linked.  Note that one wants to link 
them in the order that you want the channels to be treated.  For example, many times 
Landsat TM data is in the order of bands 1 thru 7.  However, if you would like for the 
channels to be in wavelength order, then select in order of bands 1, 2, 3, 4, 5, 7, 6 or for this 
example 1, 2, 3, 4, 5, 7, 61_30m, 62_30m. 

 

2.5 After linking the separate disk files together, one can run the Display Image, Histogram, 
List Data, Principal Components, and Reformat processors on the "logically linked" image. 
One cannot use this "logically linked" image as a base image for a Project (see section 2.6 
for the procedure to do this).  
Some additional rules and limitations on Logically Linking are: 

- One can only link image files that are being used in multispectral type image windows. 
- Image files that can be linked may contain a different number of lines and columns. The 
resulting linked image will contain the largest number of lines and columns that includes 
the union of those in the separate image disk files. Also the separate image files may 
contain a different number of data bytes, a different number of channels and they can be a 
mixture of band interleaved by line (BIL) and band sequential (BSQ) formats. (Note that 
band interleaved by sample or pixel (BIS or BIP) formats cannot be used in logically linked 
image files. One will need to change the BIS formatted file to BIL or BSQ first.) 

- All image files will be overlaid by starting with the first line and first column in the disk 
file. No provision has been provided to overlay the image files using different line and 
column offsets. 
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2.6 Combining Files into a Single New File: Use the Reformat->Change Image File 
Format… menu item to create a new disk file that contains all the channels included in the 
"logically linked" image files. The default options are usually sufficient but you can change 
them as desired. If the map projection information is known for the image and included 
with the input images, the GeoTIFF format is a good Header option to use to keep that 
information with the new image file. 

 

 
 
After selecting “OK”, you will have the opportunity to name the file before it is created. 
This new file can then be used as a base image for a project. 
 

2.7 Some Notes:  
 
 - One can also link multiple image files together that represent multi-temporal data from the 

same location, provided that line and column numbers for the given pixel ground locations 
in the separate image files from each of the times have been made to correspond. 
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2.8 FAST-L7A Format. MultiSpec will automatically link all bands in the FAST-L7A 

formatted group identified in the header if a one selects the header file such as 
…HRF.FST for reflective data (bands 1-5 & 7) and HTM.FST for thermal data (bands 61 
& 61).  

 

 
 
You can then link groups of bands if one wants (and if the images make sense to do that). 
FAST-L7A is one of the formats used for the Landsat 7 data. 
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2.9 ASTER HDF Files. MultiSpec will automatically link the ASTER channel sets 1, 2 and 
3N (VNIR) together if any one of these data sets is selected in the hdf file. The same is true 
for the SWIR set of channels (4-9) and the TIR set of channels (10-14).  See example 
below. 
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!  Exercise 3: Unsupervised Classification (Cluster Analysis) 
Requirements:  MultiSpec application and image titled “ag020522_DPAC_cd.lan”. 
Two Clustering algorithms are available in MultiSpec. They are useful in grouping similar pixels 
in the image into clusters or categories. One algorithm implemented is a simple one-pass type. 
The second is an iterative type called ISODATA. We will use the ISODATA algorithm for this 
exercise.  
To start this exercise, be sure that the “ag020522_DPAC_cd.lan” image that was used in exercise 
1 is open. Also clear any selections in the image window by striking the “Delete Key” 
A cluster analysis will be run using the image file represented by the active (top-most) 
multispectral image window. 
3.1 From the Processor menu, select Cluster… to bring up the cluster specifications dialog 

box.  Select “Do Not Save” in the Cluster Stats: popup menu.  Select “Cluster mask file” 
and select “Image window overlay” under the “Write Cluster Report/Map To” group. 

 
 This will cause a cluster map to be created as a thematic image disk file and displayed as an 

overlay on the multispectral image window. 
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3.2 Then select “ISODATA…” This will cause the ISODATA Specifications dialog box to be 
displayed. Enter 7 for the number of clusters, 100 for the convergence percentage and set 
the line and column intervals to 1 (if needed) and then select OK. 

 
3.3 You are now back to the Cluster Specifications dialog box.  Select OK to close this dialog 

box and start the clustering operation. 

 You will be prompted to enter a name for the cluster map disk file and where to save the 
file. Just use the defaults by selecting OK in the Save Cluster Map dialog box. 

 A cluster map will now be created with around 7 classes in an unsupervised manner. You 
will notice the colors change in the image window as the pixels are sorted into cluster 
classes during each iteration. After the final iteration, a thematic image file with a map of 
the cluster classes will be saved to disk.  

The text output for the cluster operation will be at the end of text output window. The 
information includes the mean values for each of the channels for each cluster for both the 
intial condition and the ending condition. If the map information is available for the image, 
the final area for each cluster is listed in the units specified in the coordinate view for the 
image window. 
Usually the convergence is set for a little less than 100 so that the process does not take too 
long to complete.  We used 100 in this example so that you have a chance to watch the 
pixels change cluster classes which illustrates the nature of the ISODATA algorithm. 

 The cluster map overlay on the multispectral image window will look similar to the 
following. 
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 You can turn the 

overlay on and off by 
using the “Red O” 
popup menu button in 
the toolbar to the right 
of the “small mountain” 
zoom button. 

 

 
 

 
 

 
3.4 Now open the cluster map thematic image file. This will be the same image as is shown in 

the overlay above but you will have more control over the cluster classes. 
 From the File menu, select Open Image… to bring up the open image dialog box. You 

may have to change the “Files of type” popup to All Files or Thematic Files.  Then select 
“ag020522_DPAC_cd_clMask.gis” and then select OK. One may need to select 
“Thematic” for the Files of Type 
popup menu.  

 The Thematic Display 
Specifications dialog box to the 
right will be displayed.  

 The default settings are fine; 
select “OK” in the Display 
Thematic Image dialog box.  
This opens a thematic image 
window.  
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3.5 The cluster class legend is on the left in the thematic image window below.  

 
 Compare the Cluster map with the original image window. Note clusters that represent 

trees, sparse vegetation, thicker vegetation, different soil colors and shadows.  
There are several things one can do to evaluate the image. One can move the cursor over a 
color chip, hold the shift key down (cursor will change to an open eye) and click the left 
mouse button down and up to cause the colors for that class to blink off and on (alternate 
between white and the color). If one holds down both the shift and ctrl keys and then click 
the left mouse button down and up, then all of the other classes will blink off and on. These 
procedures are helpful in understanding the extent of the classes in the image. 
One can also change the class color by double clicking on the color chip. 

One can change the cluster class names by double clicking on the name to the right of the 
color chip. (The list of interpreted cluster names that I come up with are: Light soil, 
Medium colored soil, Sparse vegetation (weeds), Dark soil, Dense vegetation (trees, wheat, 
weeds), Shadowed trees, Image blank. 

3.6 One can also group the cluster classes together in information groups by selecting 
Classes/Groups in the popup menu above the legend. Then drag the cluster classes into 
similar information group categories. Again one can double click on the group name to 
change the name. For example one could change the appearance of the thematic image to 
represent Bare Soil, Vegetation and Non-image informational classes.  The popup in the 
legend allows one to display the original cluster (spectral) classes. 
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!  Exercise 4:  Supervised Classification - Select Training Fields 
Requirements:  MultiSpec application and image titled “ag020522_DPAC_cd.lan”.  
One can also do a supervised classification by selecting training areas for specified classes from 
known areas.  

4.1 If a project window is open, from the Window menu, select Project, and then double click 
in the upper left to close the current project and project window. One may have been 
created during the cluster analysis.  

4.2 Now one will select training fields.  

 From the Processor menu select 
Statistics and select OK in the Set 
Project Options dialog box. (The 
default settings for this exercise are 
satisfactory.) 
A new window labeled Project will 
appear to the right of the screen that 
will be used in a moment. To select 
training fields for each class, one must 
simply "drag" a rectangular area on the 
image (or, with polygon option 
selected, click on the corners of the 
desired polygon), and then "Add that 
field to the list." Thus, 

 

Drag from the upper 
left corner to the lower 
right corner of the 
Tree training field in 
the image window. If 
upon inspection, one 
does not like the exact 
boundaries resulting, 
one may immediately 
repeat the process.  
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 Caution: A mistake that is made many times is to select training areas very near edges of a 
field. One should stay away from the edges by a couple of pixels to reduce the chance of 
edge affects. 

 Note in the Project dialog box, that the coordinates (row and column numbers) of the upper 
left corner and the lower right corner of the selected area appear in box near bottom. Now, 

4.3 Select the Add to list button. A dialog box will 
appear to allow one to name the class and give the 
field a special designation, as desired. Thus, Type 
Trees into the Class Name box and then select OK.  

 Note that one can designate the selected area as a 
training or test area. 

4.4 Since there is to be only one training field for this 
class, we are ready to select the training for the 
second training class. Thus next, 

 Drag across the second training field in the Image 
Window shown below for Wheat. 

 Select the Add to list button in the Project window. 
 Select the training areas for the rest of the six 

classes – Image blank, Weeds, Soil, Light soil. 
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 The Project Window can have four different modes – the Select training field mode, the 
Class list mode, the Field list mode and the Coordinate list mode. The modes are controlled 
by four buttons just above the list box at the bottom of the Project Window. The “>Select” 
button causes the Project window to be in the select mode. The “>Classes” button causes 
the Project classes to be displayed. The “>Fields” button causes the fields for the selected 
class to be displayed. The “>Coord.” button causes the coordinates for the selected field to 
be displayed. 

 One can delete a class by selecting the class in the class list and then selecting “Cut Class” 
in the Edit menu. One can also do the same for deleting a specific field. 

 One can also use polygonal type fields to define training classes. To do this, select the 
“Polygon Enter” checkbox in the Project Window when in Select mode. Click in the image 
window to define each corner of the polygon. Double click on the last point. To turn the 
polygon type selection off, just select the “Polygon Enter” checkbox to deselect it. 

 Note that the clustering step described in Exercise 3 can be useful in the classifier training 
step in determining how many classes might be separable in a given data set and where to 
define training areas such that the spectral characteristics of the pixels are similar. 
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!  Exercise 5: Classification 
5.1 From the Processor menu select Classify…. In the Set Classification Specifications dialog 

box which appears, select the √ near Image Selection under Classify to de-select it since, 
during this pass, it is desired to classify only the training fields in order to obtain an initial 
estimate of the quality of the class definition and training.  

 
Note that under Write classification results to: One can also select the Disk File button 
causing a disk file version of the results to be written. Since we have no need for this file in 
this case, leave this button unselected. 

Since the other default options are satisfactory, select OK and then Update to the "Update 
Project Statistics" dialog box to begin the classification.  

The classification will be complete momentarily. 
5.2 From the Window menu select Text Output, to bring the text window forward and make it 

active, since it contains the classification results. The “TRAINING CLASS 
PERFORMANCE (Resubstitution Method)” table tabulates how the pixels of each field 
and class were classified. See example table below. There should be nearly 100% accuracy 
on the training fields. If the Reference Accuracy is particularly low (say less than 50%) for 
a class, then the training pixels for that class should be reexamined and new training pixels 
selected. 
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Classification of Training Fields 
 
    TRAINING CLASS PERFORMANCE (Resubstitution Method) 
 
    Project                 Reference          Number of Samples in Class 
     Class           Class  Accuracy+ Number         1       2           3         4       5          6 
     Name            Number    (%)    Samples    Trees   Wheat Image Blank Weeds    Soil Light Soil 
 
    Trees                1     98.4      8249     8117     126           0       6       0          0 
    Wheat                2     97.5      4277      102    4170           0       5       0          0 
    Image Blank          3    100.0      1485        0       0        1485       0       0          0 
    Weeds                4     97.9      1102        2      21           0    1079       0          0 
    Soil                 5    100.0      6069        0       0           0       0    6069          0 
    Light Soil           6    100.0      3933        0       1           0       0       0       3932 
 
                     TOTAL    25115     8221    4318        1485    1090    6069       3932 
 
                  Reliability Accuracy (%)*       98.7    96.6       100.0     99.0   100.0      100.0 
 
       OVERALL CLASS PERFORMANCE (24852 / 25115 ) =  99.0% 
       Kappa Statistic (X100) =  98.6%. Kappa Variance = 0.000001. 
 
       + (100 - percent omission error); also called producer's accuracy. 
       * (100 - percent commission error); also called user's accuracy. 
 
5.3 Assuming satisfactory results, we are ready to classify the whole area.  From the Processor 

menu choose Classify…   
- Under Areas to Classify de-select Training (resubstitution) by selecting the √ by it, and, 

 - Select Image selection. Make sure that the entire area of the image is to be classified 
(lines 1-709 and columns 1-1501). Select the square button, if activated, to the left of lines 
and columns, to force all lines and columns in the image to be used. 

 - Also select Disk File under Write classification results to: so that a disk file for later use 
will be created.  

 - One can also select Image Window Overlay to cause the classification to be displayed as 
an overlay on the multispectral image window if you wish to.  

 - Also select the Create Probability Results File checkbox so that a classification 
probability map will be saved to a disk file. 

 - Then select OK.  

 - Select Save in the dialog box that follows regarding a file name for the results. We will 
use the default name and location for the output classification file and for the probability 
map file. 
As soon as the classification is complete, one will see a summary of the results displayed in 
the text window. 

5.4 You save the project using the File–>Save Project menu item. You will be presented with 
a dialog box to enter the name (or use the default name). The training and test areas that 
you selected will be saved. You can open this file up at a later time to continue your 
analyses. 
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!  Exercise 6:  View Classification Map. 
6.1 Now open the classified image named “ag020522_DPAC_cd.gis”. It should appear similar 

to the image below. This is a Thematic type image. 

 
6.2 After displaying the classified image “ag020522_DPAC_cd.gis”, from the Project menu, 

select Add as Associated Image to cause the training field outlines to be drawn on the 
image. You can change the field outline color to black using the Processor->Statistics… 
menu item and selecting “Black” in the Color popup under  the “Outline selected areas:” 
group. 
There are some things that one can do to evaluate the results. One is to move the cursor 
over a color chip, hold the shift key down (cursor will change to an open eye) and click the 
left mouse button down and up to cause the colors for that class to blink off and on 
(alternate between white and the color). If one holds down both the shift and ctrl keys and 
then clicks the left mouse button down and up, then all of the other classes will blink off 
and on. These procedures are helpful in understanding the extent of the classes in the image 
and to determine where classification errors may be. One may need to change training 
fields or add other classes if there appears to be confusion between the categories that you 
wish to identify. 
One can also change the class color by double clicking on the color chip as was done in the 
cluster section. 
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!  Exercise 7:  Classification Probability Map.  
One can view the classification probability map to evaluate which portions of the image have 
lower and higher probabilities of being classified correctly. There may be other classes in the 
image that our training fields do not adequately represent. 

7.1 Open the probability map named “ag020522_DPAC_cdProb.gis”. It should appear similar 
to the image below after associating it to the Project. This is a Thematic type image. 

 

 
 

Yellow to red colors represent a high probability of being correct. These pixels are very 
close to our training pixels for the classified class. Dark green to blues represent a low 
probability of being correct. These pixels are very far from the training pixels for all of the 
classes. The classified image though may still represent the area well enough for our 
purposes. For our classification, we could probably do a better job of separating out the 
sparse weeds from the wheat. There are probably more than the six classes that we selected 
than can be separated successfully. 
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!  Exercise 8:  Overlay Shape Files on Image Window 
Requirements:  MultiSpec application, image titled “L7_000606_Indy.tif” & inrds.shp. 
One can open ArcView Shape files (as long as an image window is opened first). A popup menu 
button will appear in the lower left of the Macintosh Image Window to allow one to turn the 
display of the shape file overlay(s) on and off. The popup menu button for the Windows version 
is next to the zoom buttons in the toolbar. The shape file will only be added to the active image 
window.  
 
The L7_000606_Indy.tif image has been provided with several shape files in the IN_themes 
folder to allow one to practice working with shape files. 
 

 
 
8.1 Display the L7_000606_Indy.tif image file in a multispectral image window using the 

File–>Open Image… menu command. You can display the image using any band 
combination that you wish. 

 
8.2 Use the File–>Open Image… menu command to open a shape file such as inrds.shp in the 

IN_themes folder.  You may need to change the filter (Files of types) in the open image 
dialog box to Shape or All.  The shape file will be overlaid onto the image window as 
illustrated above with black lines. 
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MultiSpec will automatically convert lat-long shape files to respective map coordinates for 
images in Albers Equal Area, Cylindrical Equal Area, Equirectangular, Lambert Azimuthal 
Equal Area, Transverse Mercator, Orthographic, Sinusoidal and UTM map projections. 
MultiSpec first assumes the shape file is in the same units as the map projection. If there is 
no overlap, MultiSpec checks if the input shape file units are within the range possible for 
decimal latitude-longitude degrees. If so, MultiSpec assumes the shape file is in lat-long 
units and converts them to map projection units. If the converted shape file values overlap 
with the image, then the shape file is overlaid onto the image. If a shape file has been 
converted, _ltom is appended to the shape file name in the overlay list for the window. 
(Comment: ltom stands for lat-long to meters.) 

 
8.3 One can obtain a dialog box for editing the vector line width and color in the Windows 

version by holding the shift key down before selecting the Overlay menu button with the 
left mouse button and then select the shape file overlay to be edited.  Note that … now 
follows the overlay name indicating that a dialog box will be displayed.  One can obtain 
this dialog box in the Macintosh version by holding the Option key down and selecting the 
Overlay menu button and then selecting the overlay to be edited. 

 
Change the color of the shape files lines that have been drawn to white with a thickness of 
2. 

 
8.4 Notes: 

 
- One can use the Edit->Clear Overlay menu item to remove the selected shape file from 
memory.  The list of shape files in this list will include all shape files drawn in all open 
image windows.  If one also has an image in geometric (lat-long) projection, shape files on 
these images will be treated as a separate shape files in the Edit–>Clear Overlay list 

 
- MultiSpec will draw shape files correctly on images that have a map rotation angle such 
as the level 1B Aster data. 
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!  Exercise 9:  Selecting Areas and the Coordinate View 
Requirements:  MultiSpec application and pampas_xxx.img image files. 
One can make selections of areas within an image using line-column, map or latitude-longitude 
units. The map and latitude-longitude units are only available for images where the required map 
projection information is available. Currently, MultiSpec can handle selections in latitude-
longitude for image in geometric (latitude-longitude) and UTM, Transverse Mercator, Albers 
Conical Equal Area, Cylindrical Equal Area, Lambert Azimuthal Equal Area, Sinusoidal, 
Orthographic, Krovak and a few State Plane map projections.  
 
9.1 One can use the Edit–>Selection Rectangle menu item to do this. 
 

 
 

- A checkbox is available to allow one to apply the selection to all open image windows. If 
the selections are being made in line-column units one can turn off the option to take into 
account the start line and column of the images.  If the units being used are map or latitude-
longitude units then the same area will be defined as well as possible across all image 
windows even if the pixel sizes are different. 

 
- A Preview button is available to apply the change for viewing before closing the dialog 
box.  

 
9.2 Similar capability to the Edit->Selection Rectangle menu item above, is also available 

using the coordinate views of the images and the mouse cursor. If you make a selection in 
an image window with the coordinate view in lines/column units and hold the control key 
down when making selections, the same line and column selection will be made if possible 
in all open image windows. If one also holds the shift key down when doing this, any 
difference between the start line and column values will not be used. 
 
If the coordinate view is in latitude-longitude units, the same latitude-longitude will be 
selected in all open image windows that contain the map projection information (which 
makes this possible). The same is true when selecting in map units of meters, etc. 
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The pampas_gk.img (Transverse Mercator), pampas_latlong.img (Latitude-Longitude) and 
pampas_utm.img (UTM) files can be used to illustrate these features.  The figure below 
illustrates the result of a latitude-longitude selection in one image that was copied to the 
other open image windows when the control key was used in making the selection. 

 

 
 
 

Note that the rectangle in the right image has a different shape (wider) than the selections 
in the other two images because the pixels in this image file were mapped to latitude-
longitude units and the pixels in the other two images were mapped to other projections. 
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!  Exercise 10:  Image Enhancement 
 

Requirements:  MultiSpec application and image titled “ag020522_DPAC_cd.lan”. 
Open the image if it is not already displayed in a multispectral image window following the 
guidelines given in exercise 1 (Display and Inspection of Image Data with MultiSpec).  
 
One can control the enhancement of the image in the multispectral image window by setting five 
different options in the Enhancement portion of the Display Specifications dialog box including 
Bits of color, Stretch, Min-maxes, Treat ‘0’ as and Display levels per channel.  
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10.1 The “Bits of color” default is 24 and the “Display levels per channel” default is 256 for all 
monitors now days for the maximum number of colors possible.  One can adjust to lower 
values if one wishes to see what the affects are. 

 

 
 

The figure above illustrates 256 display levels per channel (millions of colors) on the left 
and 2 display levels per channel (8 colors) on the right. 
 

10.2 The Treat ‘0’ as data setting causes 0 values to be displayed as black. However, if 0’s 
actually represent background or ‘no data’, one may want to select the background option 
to cause 0’s in all channels to be displayed as white. The figure below illustrates 0’s treated 
as black on the left and 0’s as white on the right. 
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10.3 The Stretch and Min-maxes are usually the options used to enhance different parts of the 
image. They control the process by which each possible data value in the image data is 
assigned to all possible display levels.  

 

There are three choices for Stretch:  Linear, Equal Area and Gaussian. In the case of Linear 
Stretch, gray scale intervals are equally spaced over the data range, while the Equal Area 
Stretch choice causes them to be set so that each interval represents about the same number 
of pixels. Though nonlinear, the equal area stretch will provide maximum contrast.  The 
Gaussian selection causes the distribution of the number of pixels assigned to the gray scale 
intervals to represent a Gaussian curve. If one holds the 'Option' key down (Mac version) or 
the 'Right Mouse button down (Windows version) before you select the enhancement 
popup menu with the left button, you can change the number of standard deviations that the 
data will be fit to for the Gaussian selection. The default is 2.3. 

 

 
 

Linear, equal area and Gaussian stretches are illustrated in figure above left to right. 
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10.4 The Min-maxes option allows one to select the beginning and end data values of the image 
histogram to be used for assigning the pixels in the gray scale intervals defined by the 
Stretch option. The “Entire Range” choice for this option would cause lowest data value 
possible in the image, 0 for 8-bit unsigned data, to be the first data value displayed for 
lowest display value (black) and 255 to be the last data value displayed for the highest 
display value (white).  However, if the actual range of the data is only 50 to 150, then the 
data will only be represented by grays not black to white; there will not be much contrast in 
the image. 

 

The 2 Percent Tails Clipped choice will cause the selected begin and end range of data 
values for a given channel to represent those data values in which 2 percent of them in the 
histogram are outside of the selected range.  The intent of this choice is to reduce the 
chance that a small number of extreme outlier data values in the image will unduly 
influence the display enhancement. This choice usually results in a display of the data that 
has better contrast over all.  

 

Selection of the Specify Min-Max... choice presents a dialog box (illustrated below) to 
allow one to set percent of tails clipped to be something other than 2%.  You can also set 
your own min-max values to stretch the gray levels across.  The actual data min and max 
values computed from the histogram are included in the dialog box. 

 

 
 

Entire range, 2% clip and 4% clip is illustrated below from left to right. 
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Concluding Remarks 
 
There are many other operations that one can do with MultiSpec including several Reformatting 
processes.  See the MultiSpec Introduction at the MultiSpec web site for more information. The 
MultiSpec web site is: http://dynamo.ecn.purdue.edu/~biehl/MultiSpec/.   
 
Most of the exercises included above are available as tutorials at the MultiSpec web site: 
http://dynamo.ecn.purdue.edu/~biehl/MultiSpec/tutorials.html. The images that are used in the 
tutorials are available for download from the web site. 
 
Or contact Larry Biehl at biehl@purdue.edu with questions. 
 
 


